สืบเนื่องมาจากว่า เวลา npm install Library ต่างๆ แล้ว มันจะเป็น version แบบกว้างๆ คือ ^2.4.0 แบบนี้ใช่มั้ย เนื่องจากแบ่งเป็น semver บางที มันจะไป Install เวอร์ชั่นอืื่นๆ เพราะ ^ (Compatible version) เช่น เราระบุไว้ ^2.4.0 อาจจะไปติดตั้ง v2.5.0, v2.9.0 ก็ได้ มันจะติดตั้ง latest ตอนเรา install

ทีนี้ วิธีแก้ปัญหาคือ ลบ ^ ออกซะ ใน package.json

หรือวิธีง่ายๆ เวลาติดตั้ง ก็ใส่ option ให้มันด้วย

npm install <LIBRARY> --save-exact

หรือง่ายกว่านั้น ตั้งเป็น global ไปเลย

npm config set save-exact true

เช็คดูว่า npm config เราโอเคมั้ย

npm config list

ไฟล์ config อยู่ที่ ~/.npmrc

Done!